LibreOffice Server Installation GUI

Hi there!

After a long time of inactivity, here is something I have been working on for quite a long time. please, don’t be mad and download it. If there is an update, you will be updated within 7 days.

I am proud to present you my program “LibreOffice Server Installation GUI” with the following features:

  • Ability to perform an admin / server installation [NOT Possible due to a bug in LibreOffice, but as soon as it is fixed it is working fdo#54304]
  • Opening the bootstrap.ini and showing you the snipped, which should be changed
  • Saving the bootstrap.ini with only one click (Administrative right might be compulsory!)

That’s it, but it might be a benefit to the QA team ;)

 

Now, it’s screenshot time:

 

Feedback is appreciated

13 thoughts on “LibreOffice Server Installation GUI”

  1. Hi Florian, indeed, such a GUI Helper might ease things for beginners. I did a test and tried to install a 3.6.4 Daily. I found a small problem, when I browsed for the .msi, your GUI Helper did not recognize / show the document in the Explorer dialog, I had to add “*.msi” to the file name pane so that the .msi became visible.
    I created a new installation folder in “Configure installation directory”, but it was not accepted by the GUI Helper. I teeminated the GUI Helper, started again, but it did not accept my “C:\LibO_Server\LOM36\20121022″. Here I stopped further tests. Any Ideas?

      1. “libreoffice-3-6~2012-10-22_23.52.55_LibO-Dev_3.6.4.0_Win_x86_install_en-US.msi”. I stated that the problem appeared when I selected the “Installation directory”, but you have a different suspect?

        1. I will try your update with the next Build I install on my PC for permanent use. BTW, I normally install 4 Help languages, is it possible or planned for future to install more languages?
          Currently I use a trick, what is more a tool to save time and not to ease things for beginners: I have in install.bat with contents

          msiexec /a install_multi.msi
          msiexec /a help_en-us.msi
          msiexec /a help_de.msi
          msiexec /a help_fr.msi
          msiexec /a help_es.msi

          I simply copy it into the folder with installation files, installation files renamed to the simple names in the batch, start it from command line.

        2. Hi, I downloaded from link in comment Tue 23.10.2012 at 15:56, uninstalled old GUI Server Installation Helper, installed new one, started without my action, I selected
          C:\Users\user\LibOinstall\3572\LibO_3.5.7rc2_Win_x86_install_multi.msi
          C:\Users\user\LibOinstall\3572\LibO_3.5.7rc2_Win_x86_helppack_de.msi
          C:\LibO_Server\3.5.7.2
          (I created that folder before I started this test)
          Replaced bootstrap.ini String by “UserInstallation=$ORIGIN/../Data/settings”
          Clicke “Start Installation”

          I saw DOS window for a short moment, but that disappeared immediately and nothing became installed.

        3. Hmmm, I am going to investigate this….

          Look at any root folder “c” “D” … It should be there…

          AND at the end you have to open the bootstrap.ini and edit it manually…

  2. Today I installed “libreoffice-3-6~2012-10-31_08.03.29_LibO-Dev_3.6.4.0_Win_x86_install_en-US.msi” GUI Installer Version 1.9.5.0, worked without problems

Comment

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s